Menu
CHIP Speedtest

Sčítání obsahů buněk v závislosti na podmínkách

18.06.2011 16:34 | Redakce Chip
Při sčítání nemají být do výpočtu zahrnuty všechny prvky zvolené oblasti. Jejich výběr může záviset na vlastnostech jednotlivých hodnot nebo na hodnotách jiných buněk, podmínky jsou částečně proměnné.

Pro podmíněné načítání hodnot nabízí Excel rozličné možnosti a funkce. Jejich správný výběr závisí na druhu podmínek. Jestliže pro každou relevantní hodnotu platí pevná podmínka, použijte funkci »SUMIF«. Je-li třeba respektovat více podmínek, je od Excelu 2007 navíc k dispozici funkce »SUMIFS«. Při variabilních podmínkách budete naproti tomu potřebovat maticový vzorec nebo funkci »SOUČIN.SKALÁRNÍ«. Rozdíly objasní následující příklad. Předpokládejme, že v buňkách »A1« až »A10« jsou uložena data a v buňkách »B1« až »C10« různé hodnoty, které slouží jako podmínky.
PEVNÁ PODMÍNKA: Nyní mají být sečteny všechny hodnoty ve sloupci »A«, pro něž je v odpovídající buňce sloupce »B« hodnota větší než »10«. K tomu použijeme vzorec

=SUMIF(B1:B10;">10";A1:A10)

První argument »B1:B10« definuje oblast, která má být vyhodnocována, za ním následuje podmínka »">10"«; pamatujte přitom, že podmínky obsahující symboly nebo operátory musí být uvedeny v uvozovkách. Poslední argument »A1:A10« pak určuje sumarizovanou oblast. Oblasti pro podmínky a data mohou být i identické, takže pak by stačil vzorec

=SUMIF(A1:A10;">10")

Počínaje verzí Excel 2007 rozšiřuje funkce »SUMIFS« tento princip na maximálně 127 podmínek. Mějte však na paměti, že je u ní jiné pořadí argumentů. Zde se jako první uvádí sumarizovaná oblast. Za ní následují vždy jedna oblast kritérií a příslušná podmínka, přičemž oblasti se vždy zadávají odděleně.
Například vzorec

=SUMIFS(A1:A10;B1:B10;">10";C1:C10;"<100")

sečte všechny hodnoty sloupce »A«, pro něž jsou korespondující hodnoty sloupce »B« větší než »10« a odpovídající hodnoty sloupce »C« menší než »100«.
VARIABILNÍ KRITÉRIA: Jsou-li podmínky sumarizace komplexnější, například »jestliže je hodnota ve sloupci B větší než odpovídající hodnota ve sloupci C«, je pro vyhodnocení nutno použít maticový vzorec. Výběr hodnot, které mají být vzaty v úvahu, je realizován vynásobením logickou hodnotou. Zadejte tedy například

=SUMA(A1:A10*(B1:B10>C1:C10))

a vzorec bezpodmínečně ukončete klávesovou kombinací [Ctrl]+[Shift]+[Enter] – Excel pak zobrazí vzorec ve složených závorkách. Stejného výsledku v tomto případě dosáhnete také funkcí

=SOUČIN.SKALÁRNÍ(A1:A10;1*(B1:B10>C1:C10))

Zde je důležité vynásobení druhého argumentu číslem »1«, které převede logickou hodnotu na číslo.
Upozornění: Prakticky ve všech případech můžete sumarizaci přehledně realizovat použitím pomocného sloupce. To lze doporučit zvláště během vývoje tabulkové kalkulace k překontrolování výsledků komplexních vzorců.

Zajímavosti ze světa IT v e-mailu

Stačí odeslat svoji e-mailovou adresu


Odesláním formuláře souhlasíte se zpracováním svých osobních údajů a užitím pro marketingové účely vydavatelství Burda Praha, spol. s.r.o.

Předplatné / nákup chipu Digitální edice chipu Aktuální vydání