Menu

Výpočet střední hodnoty v oblasti buněk

08.01.2010 00:00 | Redakce Chip
Z jisté množiny dat potřebujete určit střední hodnotu. Prázdné buňky a nulové hodnoty mají být ignorovány. Excel přitom má vzít v úvahu jen hodnoty, které vyhovují určitým kritériím.

Výpočet střední hodnoty v dané oblasti buněk

Z jisté množiny dat potřebujete určit střední hodnotu. Prázdné buňky a nulové hodnoty mají být ignorovány. Excel přitom má vzít v úvahu jen hodnoty, které vyhovují určitým kritériím.

Excel 2007 vám úkol usnadní díky novým funkcím AVERAGEIF a AVERAGEIFS. Ve starších verzích je však můžete analogicky sestavit z funkcí PRŮMĚR a KDYŽ.

Předpokládejme, že vaše tabulka má ve sloupci A jména prodejen, ve sloupci B města a ve sloupci C obraty. Chcete se dovědět, jaký byl průměrný obrat například za Brno. Hodnoty nižší než jistá mez přitom nemají být brány v úvahu, neboť se pak pravděpodobně jedná o nové prodejny.

Z hlediska výpočtu je tedy třeba zprůměrovat hodnoty ve sloupci C, u nichž se ve sloupci B vyskytuje daný textový řetězec. Ovšem pouze tehdy, pokud samotná hodnota není menší než dané minimum. V Excelu 2007 k tomu v nějaké volné buňce použijte vzorec

= AVERAGEIF(B2:B20;"=*Brno";
C2:C20)

Zde »B2:B20« určuje oblast kritérií, která má být prohledána na výskyt vzoru »*Brno«. Podle výsledku pak vstoupí do výpočtu odpovídající hodnoty z oblasti »C2:C20«. Ve starých verzích Excelu použijte podle téhož schématu funkci

{ =PRŮMĚR(KDYŽ(B2:B20="Brno";
C2:C20))}

Složené závorky přitom nezapisujte - Excel je doplní automaticky, jakmile stisknete klávesovou kombinaci [Ctrl]+[Shift]+[Enter]. Pamatujte, že zde musí existovat přesný souhlas s hledacím pojmem.

Trochu složitější je druhá část úlohy, neboť zde je třeba kontrolovat dvě kritéria. V Excelu 2007 to zařídí nová funkce AVERAGEIFS. Povšimněte si jiného pořadí argumentů: Za průměrovanou oblastí následují střídavě jednotlivé testované oblasti a příslušná kritéria. Zadejte tedy:

=AVERAGEIFS(C2:C20;B2:B20;
"=*Brno";C2:C20;">999")

Ve starých verzích Excelu se opět uplatní maticový vzorec. Ke spojení kritérií zde použijte vnořené funkce KDYŽ. Potřebný vzorec pro naši úlohu tedy bude vypadat takto:

{ =PRŮMĚR(KDYŽ(C2:C20>999;
KDYŽ(B2:B20="Brno";C2:C20)))}

Ani zde nevkládejte složené závorky a nezapomeňte zadání ukončit klávesovou kombinací [Ctrl]+[Shift]+[Enter].

Zajímavosti ze světa IT v e-mailu

Stačí odeslat svoji e-mailovou adresu


Odesláním formuláře souhlasíte se zpracováním svých osobních údajů a užitím pro marketingové účely vydavatelství Burda Praha, spol. s.r.o.

Předplatné / nákup chipu Digitální edice chipu Aktuální vydání